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La programmation des PIC en C — Installation et premiére simulation
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La programmation des PIC en C — Installation et premiére simulation

Introduction

Les microcontréleurs PIC de la société Microchip, sont depuis quelques années dans le "hit
parade" des meilleures ventes. Ceci est en partie di a leur prix trés bas, leur simplicité de
programmation, les outils de développement que I'on trouve sur le NET.

Aujourd'hui, développer une application avec un PIC n'a rien d'extraordinaire, et tous les outils
nécessaires sont disponibles gratuitement. Voici I'ensemble des matériels qui me semblent les
mieux adaptés.

Ensemble de développement (éditeur, compilateur, simulateur) :
MPLAB de MICROCHIP  http://www.microchip.com
Logiciel de programmation des composants:
IC-PROG de Bonny Gijzen  http://lwww.ic-prog.com
Programmateur de composants:
PROPIC2 d'Octavio Noguera voir notre site http://electronique-facile.com

Pour la programmation en assembleur, beaucoup de routines sont déja écrites, des didacticiels
trés complets et gratuits sont disponibles comme par exemple les cours de BIGONOFF dont le site
est a 'adresse suivante http://fabcelectronique.com/bigonoff.

Les fonctions que nous demandons de réaliser a nos PIC sont de plus en plus complexes, les
programmes pour les réaliser demandent de plus en plus de mémoires. L'utilisateur est ainsi a la
recherche de langages "évolués" pouvant simplifier la tdche de programmation.

Depuis l'ouverture du site http:/lelectronique-facile.com, le nombre de questions sur la
programmation des PIC en C est en constante augmentation. Il est vrai que rien n'est aujourd’hui
disponible en francgais.

Mon expérience dans le domaine de la programmation en C due en partie 8 mon métier
d'enseignant, et a ma passion pour les PIC, m'a naturellement amené a l'écriture de ce
didacticiel. Celui-ci se veut accessible a tous ceux qui possédent une petite expérience
informatique et électronique (utilisation de Windows, connaissances minimales sur les notions de
base en électronique comme la tension, le courant, les résistances, les LEDS...).

Je ne traiterai ici que la programmation et la simulation. Si vous désirez essayer vos

ceuvres avec un microcontrdleur , il vous faudra réaliser tout seul un programmateur de composant
et trouver un logiciel de programmation.
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Structure de ce document

Ce document est composé de chapitres. Chaque chapitre dépend des précédents. Si vous
n'‘avez pas de notion de programmation, vous devez réaliser chaque page pour progresser
rapidement.

Le type gras sert a faire ressortir les termes importants.

Vous trouverez la définition de chaque terme nouveau en bas de la page ou apparait pour la
premiére fois ce terme. Le terme est alors en italique.

La couleur bleue est utilisée pour vous indiquer que ce texte est a taper exactement sous cette
forme.

La couleur rouge indique des commandes informatiques a utiliser.

Le matériel nécessaire

Un éditeur’, compilateur assembleur?, simulateur”.
Nous utiliserons MPLAB version 6.3 ou supérieure. Cet ensemble est gratuit et disponible
sur le NET (voir I'adresse plus haut).

Un compilateur C*:
Nous utiliserons CC5X version 3.1l ou supérieure, dont une version gratuite pour moins de
1024 octets de code est disponible sur le NET (Voir I'adresse sur le site).
CC5X est compatible avec MPLAB 6. Une fois copié sur le disque dur et déclaré, son
utilisation est transparente.

Installation des deux logiciels

Installation de MPLAB 6.3

Vous possédez le fichier MPLABG630full.zip, décompressez ce fichier, vous obtenez un fichier
exécutable unique MP3000.exe. Exécutez ce programme et suivez les indications (placez le
logiciel a I'endroit que vous désirez).

Modification lors de l'installation d'une version postérieure a 6.42

Pour accéder au débugging, il est nécessaire de corriger le fichier "TLCC5X.INI" qui se trouve
dans le répertoire "LegacyLanguageSuites" de MPLAB. Il faut remplacer "Target=HEX" par
"Target=COD".

Installation de CC5X

Vous possédez le fichier cc5x3lfree.zip. Créez un répertoire CC5X ou vous voulez.
Décompressez tous les fichiers de cc5x3lfree.zip, dans le répertoire CC5X que vous venez de
creéer.

Voila, c'est fini.

! Logiciel permettant I'écriture du programme encore appelé code source.

2 Transforme le code assembleur, en une suite de nombres compréhensibles par le microcontréleur.
* Permet de simuler I'état du microcontrleur avec un ordinateur.

* Transforme le code C en code assembleur.
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Déclaration du compilateur CC5X dans MPLAB

Lancez MPLAB IDE
Ouvrez la fenétre Projet > Set Language Tool
Locations...

L e T i .- i

Set Language Tool Locations =]

— Registered Tool
=) B Knudsen Data CC5A4

Default Search Paths & Directories
t- B Knudsen Data CCBE

|- Byte Craft fizzembler & C Compiler

t- CC5 C Compiler for FIC12/14/16/118
t- HI-TECH PICC Toolsuite

t- HI-TECH PICC-18 Toolsuite

=

 Location
IE:\Plogram FileshCCBACchw exe

Browse... |

Cancel | Aappir

[ o ]

Help |

Select Language Toolsuite

Active Toolsuite:

CCE C
MPASM
MPLINE

Ouvrez la fenétre Projet > Select
Language Toolsuite...

— Toolsuite Contents

Déclarez I'emplacement du
compilateur CC5X comme ci-contre.
Validez par OK.
I
[x]

B k.rudzen D ats CCGx

Compiler

r— Location

Choisissez I'outil CC5X comme ci-

IC:'\F'rogram Filez\CCB\Cobw exe

Browse... |

contre, validez par OK

Help |

Cancel |

[ o ]

Le compilateur est maintenant déclaré, cette op
créez plusieurs projets, plusieurs programmes.

ération n'est plus a refaire, méme si vous

Page 5/12




La programmation des PIC en C — Installation et premiére simulation
r L] ' L}
Création d'un projet

Le projef® que nous allons créer s'appelle clignotement.

Nous allons modifier I'état de la patte RAO d'un PIC 16F84A ( patte 17 ), cadencé a 4 Mhz par
un quartz. Cette patte passera de I'état 1 ( +5V mesurés au voltmétre sur la patte du PIC) a I'état 0
(OV mesuré au voltmeétre sur la patte du PIC), puis de I'état 0 a I'état 1 et recommencera infiniment.

Créez un répertoire que vous appellerez clignotement dans le dossier "Mes documents".
Créez un nouveau projet sous MPLAB IDE grace a la commande Projet > New..., et
remplissez la fenétre comme ci-dessous.

— Project Mame

Iclignotement

— Project Directory

IC:\M ez documentsholignotement

Help | ak Cancel

Validez par OK.

L'ensemble des fichiers utiles au projet s'affiche dans la fenétre nommée clignotement .mcw.

B clignotement. mcw S=1E
[ = clignotement mep
Source Files
Header Files
- Object Files
Library File
oo Linker Scripts

® Fichier contenant toutes les indications nécessaires a la programmation du PIC.
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Déclaration des options

Il est nécessaire de :
-choisir un composant;
-configurer les bits d'option;
-déclarer le répertoire des fichiers inclus
-sélectionner I'option "simulation";
-choisir la fréquence du quartz,
-sauvegarder le projet. selectDevie

—Micrachip Programmer Toal Support

Choix du composant (@ PICETARTPlus @ MPLABICD 2
) PROMATE N @ FlICkit1
Chaque microcontréleur posséde des caractéristiques @ MPLAD P3
distinctes. Il est donc indispensable de choisir dés le départ un
composant. Ouvrez la fenétre Configure > Select device... ~Microchip Debugger Tool Support
Choisissez le composant PIC16F84A comme ci-contre. Validez @ MPLAB SIM @ MPLABCD 2
par OK. @ MPLAB SIM30
WP LAB ICE 2000 TP LAB ICE 4000
DPCM1 EXH1 @ o Module

o]i8 I Cancel | Help |

Configuration des bits d'option

Certaines fonctions du composant doivent étre déclarées ou non. Cette déclaration servira pour
le simulateur et le programmateur de composant.
Ouvrez la fenétre Configure > Configuration Bits..., remplissez la fenétre comme ci-dessous.

= Configuration Bits BEA
Address Value Category Setting
2007 3FF9 Cscillator XT

Watchdogy Timer Off
Power Up Timer Off
Off -

-Oscillator : choix du type de composant servant a cadencer le microcontréleur.

-Watchdog Timer : initialisation du composant en cas de probléme.

-Power Up Timer : temporisation au démarrage permettant la stabilisation de la tension
d'alimentation.

-Code Protect : code de protection du composant.

Fermez la fenétre par l'icbne fermer en haut a droite.
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Déclaration du répertoire des fichiers inclus

Build Options =]
General | CCB% € Compiler | MPASH | MPLINK |
Certaines données spécifiques au composant et :
., . . . Output Directory, $EINDIR]:
nécessaires pour CC5X sont disponibles dans des
fichiers du répertoire CC5X. Il est indispensable de | [Beve, |
déClarer ce répertOire. Intermediates Directary, $(TMPDIR]:
Ouvrez la fenétre Project > Build Options... > #ssembler Include Path, $AINDIR):
Project. Remplissez la ligne Include Path par le | Browse..._|
chemin du répertoire ou se situe le fichier .inc. Include Path, ${INCDIR)
IE:\Progra"1\EC5\l Brawse... |
Selon le systéme d'exploitation utilisé, les noms Library Path, ${LIEDIR:
!on_gs ne sont pas acceptés. Il est alors | Bowss.._ |
indispensable de rempllacer ce nom par son nom LinkerScrt Path, SILKFDIF
sous DOS comme ci-contre pour le répertoire | prowe._|

Program Files.

Help | Suite Defaults |

[x]

] I Annuler | Appliguer

Choix de I'option de simulation

Nous souhaitons faire une simulation de notre programme. Il est obligatoire de le déclarer afin
de créer lors de la compilation les fichiers nécessaires. Cliquez sur Debbuger > Select Tool >
MPLAB SIM. Une barre d'outil contenant les icbnes de simulation se rajoute.

S I A

Choix de la fréquence du quartz pour la simulation

Simulator Settings HE

. , . .. Clack. |Break Dptinn&l Trau:e.f'F'in&I Limitationsl
Il est maintenant nécessaire de choisir une

fréquence de quartz pour la simulation. Ouvrez

la fenétre Debugger > Setting... — Uﬂnitsh:-i ”
o . |E " KHz
Choisissez une fréquence de quartz de 4 Uz

MHz. En tapant 4 pour Fréquency et en
cochant 'unité MHz.

Validez par OK

] I Annuler Sppliauer

Sauvegarde du projet

Sauvegardez vos options par la commande Project > Save Project.
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Edition et compilation

Le projet est sauvegardé, vous pouvez le fermer si vous le désirez. Pour I'ouvrir a nouveau
cliquez sur File > Open Workspace...

Nous allons écrire le programme correspondant a notre application. Cliquez sur File > New.
Une fenétre nommée Untitled* s'ouvre. Saisissez dans cette fenétre le programme ci-dessous
correspondant a Il'application que nous désirons. Attention : ce programme comporte
volontairement une erreur, que nous allons résoudre avec le compilateur.

/I Ceci est un commentaire car il commence par //

/I La sortie RAO du composant clignote
/I RAQ est la patte 17 du microcontrdleur

/I Attention de respecter les majuscules

void main(void)

{
RAO = 0; /[ Initialisation des pattes du microcontréleur
TRIS = 0b00000000;
for (;;) // La suite du programme s'effectue en boucle
RAO = O, Dans: Iaclignotement j gl
RAO = 1;
}
}
Enregistrez votre programme avec File > Save. Et remplissez la
fenétre comme ci-contre, cliquez sur Enregistrer. . ——
Type: IAIISourc:e Files [".c:;".h;“.asm;".as;*.inc;".s;".bj Annuler |
Encoding: IANS| d

La fenétre change alors de nom et de nouvelles couleurs apparaissent.

B C:AMes documentsiclignotement\clignotement.c [=(o] =]

A Ceci est un commentaire car il commence par FF =i

S4 La sortie BAD du composant clignote
4f BAD est la patte 17 du microcontrdleur

ff attention de respecter les majuscules

roid main(woeid)

{

BAG=0; 4 dinitialization des pattes du nmicrocontrileur
TRIS =0b0OOOOOCL0;

for (:;) £f la suite du programme s'effectus en boucle
{

PAD=0;

PAD=1;

A o

Page 9/12



La programmation des PIC en C — Installation et premiére simulation

Le fichier que nous venons de créer doit maintenant étre déclaré dans
le projet comme fichier source. Pour cela, cliquez sur le bouton droit de
la souris lorsque le curseur est sur "Source Files". Un menu apparait
choisissez la commande Add Files.

Add Files to Project [ ]=]
E xplarer -

I@ clignatement j ﬁl

Déclarez  votre  fichier
clignotement.c comme source
et cliquez sur Ouvrir.

Hom : Iclignntement c
B clignotement. mcw [_To]=] Tupe: ISource Files [*.C* A5M) j Annuler |
=l clignotement.mcp™

E| Source Files
o clignotement.c

- Header Files

- Object Filez

i Library Filez

o Linker Scripts

La fenétre prend alors I'apparence ci-contre.

Maintenant, tout est prét pour la compilation. Cliquez alors sur l'icbne Build

compiler votre programme.

W clignotement. mcw =[] =]

=l clignotement_mcp
Sourre Files

Lirker Secripts

|

Une fenétre s'ouvre. Si celle-ci ressemble a la fenétre ci-dessous, votre systéme ne
prend pas en charge les noms longs. |l faut alors revenir a la déclaration du répertoire
des fichiers inclus afin de modifier "Program Files\CC5" par "Progra~1\CC5".

= Output
Build | Find in Files |

=10] ]

Deleting intermediary files. .. done.

CCEX Version 3.1I, Copyright {c) B EKnudsen Data, Horway 1992-2003

——» FREE edition, 8-16 bit int, 24 bit float, 1k code., reduced optim.
OPTION ERROE: Duplicate file name or option error 'Files-CCEH'

BUILD FAILED: Thu Oct 02 12:53:21 2003

Executing: "C:“Program Files~CCE-Cchx.exe" clignotement .o —CC —fINHESH —pleF844 -IC:“Progra
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Vous devez, si tout va bien, aprés compilation obtenir la fenétre ci-dessous.

B Output
Build | Findlin Files |

HEEIE

Deleting intermediary files. .. done.

CCS5X Version 3.1I, Copyright (c) B Enudsen Data. Horway 1992-2003
——>» FREE edition. 8-16 bit int. 24 bit float. 1k code. reduced optim.
clignotement . c:

TRIS =0b0O0000010;

Error[1l] C:~Mes documents-clignotement~clignotement . c 11 : Symbol 'TRIS'
wrong spelling or letter case mnismatch. Otherwise a new symnbol
definition i=s reguired: wariable, function, macro, etc.)

BUILD FAILED: Thu Oct 02 12:48:40 2003

Executing: "C:~Program Files~CCECobx . exe" clignotement . o —CC —fINHHSH -pleF84i -IC:“Prog

Ra0=0: <4 initialiszation des pattes du microcontrdleur

iz undefined (T

Error options: —-sw: no warning details -ed: no error details -eLl: list details

-

E

Cette fenétre nous annonce que la commande TRIS n'est pas définie. En effet la vraie

commande est TRISA. Tapez TRISA =0b00000000; au lieu de TRIS =0b00000000;

Cette fois, votre programme est corrigé. Compilez a nouveau pour obtenir la fenétre ci-dessous.

= O utput
Build | Findin Files |

HE e

Toip — LIOCuRH
RiH: 00k XXX
RAM: 20h
FAHM: 40k © *%®EEEENE XXXEEEENE

RAM usage: 0 bytes (0 local), 68 bytes free
File 'clignotement fcs'

Optimizing — removed 0 instructions (-0 X)

File 'clignotement . war'

File 'clignotement . asn'

File 'clignotement . lst'

File 'clignotement . cod'

File 'clignotement . occ'

File 'clignotement hex'

Total of 10 code word=s (0 X)

EESTRICTIONS on commercial usage applies as described in file readne.txt
Loaded C:-Mes documents™clignotementclignotement . HEX
BUILD SUCCEEDED: Thu Oct 02 12:51:52 2003

< |

a

Certaines indications importantes apparaissent :
-les octets en RAM® utilisés:;
-les lignes optimisées (ici 0%);
-les différents fichiers créés;

-la partie de mémoire utilisée (ici 10 instructions machines, soit moins de 1% noté 0%);

® Mémoire a accés rapide ou le microcontréleur peut écrire a tout moment.
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Simulation

Nous arrivons a la derniére phase: tester notre programme par simulation.

Nous allons dans un premier temps "Animer" le programme, puis le faire fonctionner en "pas a
pas", ensuite I'exécuter jusqu'a une instruction.

Avant tout, il nous faut ouvrir certaines fenétres afin d'observer le fonctionnement interne du
PIC.
Il est possible :
-d'observer un bit’, un octet®, une sortie® grace a la commande "Watch" du menu "View".
Pour observer RAO, Choisissez RAO dans le menu déroulant a cété de "Add Symbol", puis
cliquez sur "Add Symbol".

B Walch HEE B
Add SFR ”EEADH vl Add S_I,Imbl:uI”H.-’-\D vI
Address | Symbol Name I Value |
ooos RAD oo

[wiatch1 watch2| watch 3| watch4|

-d'observer la RAM du microcontréleur par la fenétre "File Registers” du menu "View".
-d'observer le programme dans le microcontréleur par la fenétre "Program Memory" du

menu "View".
-d'observer certains octets importants (Registres) grace a la fenétre "Special Function
Registers" du
menu "view".

Cliquez sur l'icone "Reset" Ef ( touche F6) pour mettre a 0 le programme.

Cliquez sur "Animate" or pour voir le programme se dérouler. Une fléche verte se positionne
sur l'instruction qui va s'exécuter, Certaines identités du microcontréleur se modifient (observez
surtout RAQ), elles sont signalées par du rouge. dans les différentes fenétres. Evidement, vu la
vitesse de traitement, nous ne voyons pas grand chose du programme.

Cliquez sur "Halt" il (touche F5) pour arréter I'exécution.

Pour ne simuler qu'une seule instruction, cliquez sur "Step Into" o (touche F7).

Pour exécuter le programme de la position actuelle jusqu'a une autre position,
déplacez le curseur de souris sur la ligne correspondante a la position a atteindre, cliquez
sur le bouton droit de la souris, un menu s'affiche, choisissez la commande "Run to
Cursor".

Voila, vous connaissez maintenant les opérations les plus importantes pour utiliser
MPLAB en langage C.

” Le plus petit élément informatique. Il peut prendre I'état 0 ou 1.
® Ensemble de 8 bits.
% Patte du microcontréleur sur laquelle on veut faire apparaitre un 0 (0V) ou un 1 (5V).
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